Install

Firelance

2. Installation

2.1 How to obtain Firelance

go to mumbleface.net/firelance

2.2 Requirements

NetFilter (any new Linux kernel 2.4 or above)

jwCGI library version 1.27 or above. Get it at http://sourceforge.net/projects/jwcgi/
To compile and install the jwCGI library
myconsole:~$ ./configure
myconsole:~ make
myconsole:~ make install

2.3 Compilation and installation

Just issue the ./configure; make; make install

 myconsole:~ ./configure
 myconsole:~ make
 myconsole:~ make install

commands in the source directory.

Alternatively:
Pass your cgi directory to the configure script with the –with-cgibin directive, i.e.

./configure --with-cgibin=/var/www/cgi-bin

Pass the web server image directory to the configure script, i.e.

./configure --with-imagepath=/var/www/html/images

configure will create the directories if they do not exist.
e.g.

./configure --with-cgibin=/var/www/cgi-bin --with-imagepath=/var/www/images